Back to overview
Downtime
DEN region unavailable
Oct 19 at 04:28am UTC
Affected services
Denver, Colorado (US)
Resolved
Oct 19 at 10:19pm UTC
The faulty hardware was replaced and the region is back online
Affected services
Denver, Colorado (US)
Created
Oct 19 at 04:28am UTC
DEN region was unavailable due to a networking failure on a downstream cloud provider
Affected services
Denver, Colorado (US)