Back to overview
Resolved

Elevated errors of 502 on database queries

Aug 4, 2026 at 10:18pm UTC
Affected services
Turso API
AWS us-east-1 (N. Virginia)

Resolved
Aug 4, 2026 at 11:06pm UTC

We had identified and resolved the issue. The issue was a software issue that brought a particular multitenant server down, which then cascaded due to retries to a load issue in the routing layer increasing the blast radius of the incident. We estimate that around 30 customers were affected and we deeply apologize for the disruption to those affected

Created
Aug 4, 2026 at 10:18pm UTC

The router component is experiencing a high number of 502. At the moment, we only see databases in us-east-1 affected but are monitoring the situation and working on a mitigation